Update An engagement not working properly via api


#1

@dadams Hi bro, I wish to update an engagement like this.

First I tried like this:

<cfset stFields =
'{
"engagement": {
"ownerId": 9901323,
"timestamp": 1482208440000
},
"metadata": {
	"body": "** Activity Created on 12/20/2016 at 4:34 ",
	}
		}'
> 

Then tried like this:

<cfset stfields = '{

"engagement": {
	"active": true,
	"ownerId": 9901323,
	"type": "TASK",
	"timestamp": 1482217140000
},
"associations": {
	"contactIds": [23853936]
},
"metadata": {
	"body": "** Activity",
	"status": "NOT_STARTED",
	"forObjectType": "CONTACT"
}

}'>			

here’s the engagement id is 202073743.

I get this output only.how to update this engagement.please help me on this.It doesn’t shows any success message or error message.


#2

@boopathi_s Can you show us where you make the call as well so we can see how you formed it?


#3
 <cfhttp url="https://api.hubapi.com/engagements/v1/engagements/202073743?hapikey=xxx"       method="PUT" result="httpResp" > 
 <cfhttpparam type="header" name="Content-Type" value="application/json" /> 
 <cfhttpparam type="body" value="#stFields#">  
 </cfhttp> 
 <cfdump var="#httpResp#" label="HTTP response"> 

I resolved the issue bro…It’s my fault only…thanks for help bro


#4

@boopathi_s Any time I’m glad you figured it out!