Upgrade jQuery to version 3


#1

Hi all,

I'm curios if there's a way to upgrade jQuery under settings? In the settings, it only shows two old versions which are 1.7.x and 1.11.x. Is it possible to upgrade to a more recent version at least version 2 or best version 3?

Thanks in advance,
Andrew


#2

anyone have an answer for this?


#3

The exact words from Zack (Hubspot staff).

Thanks for reaching out to us with your question regarding the ability to upgrade the version of jQuery used within HubSpot.

At this time, this is not a functionality that HubSpot currently offers directly within the UI. That being said, you should be able to add this manually by attaching it as a separate JavaScript file within HubSpot, or referencing the version of interest from jQuery's CDN within your site or footer HTML.

Hope this helps,
Andrew