Use webhook endpoints


#1

We have tried to use the url of endpoints that we have been told in the help
https://knowledge.hubspot.com/es/articles/kcs_article/workflows/how-do-i-use-webhooks-with-hubspot-workflows , http://requestb.in , but it does not work. We have tested again that it does work, https://requestbin.fullcontact.com, where the webhook does leave the data, but then it can not be obtained from our application.

We would need to know a web of EndPoints where we can leave the data so that our application can later read them.

On the other hand, We have also tried to put a URL in the webhook (it is a web service of ours done through REST) ​​so that they are directly on the site. Tested to recognize data such as sequence, string and error.
If it is recognized as an object, there is no error, but if an empty string has been obtained, the data does not. (Attached Screenshot)

However, it does work correctly (Correction of a data type) (Attached Screenshot)
The only explanation that is found is the way to send data through POST in Hubspot, it is done in a special way that prevents communication. Can you tell us?

Hubspot1


#5

Welcome, @rgimenez!

I'm happy to help, but I'm having a bit of difficulty understanding your issue.

It sounds like your workflow webhook successfully POSTs contact data in JSON to your RequestBin URL, but your application cannot obtain it. RequestBin URLs are only meant to be used for testing; you should not use RequestBin addresses for production purposes.

I believe you are asking for a list of webhook URLs which your application can use. I cannot provide such a list because you should be using your own webhook URL — not any public address.

It also seems you tested with the URL https://10.claveimobility.com:4130/Service1.svc/Hubspot. If you created this URL just to receive HubSpot webhooks and no error is returned, where are you encountering a problem? The contact data is formatted in JSON and is passed in the raw body.