Webhook attempt failed due to an unrecognized error


#1

When I see the webhook monitoring, all the attempts have a Failure, and displays the message: "Webhook attempt failed due to an unrecognized error.", My webhook worked fine previously with http, but when migrating to https, this no longer works.


#3

Welcome, @yohanromeroc.

Happy to take a closer look. Can you share your developer Hub ID and app ID?

Also, can you confirm whether you're able to manually POST to https://yoursite.com/WebServices/rest/... using a client like Postman? I want to determine whether the issue is isolated to HubSpot's webhook POSTs.


#4

Hi Issac,

Thanks for your reply.

My HubID is 521251 and the App ID is 27910. When I POST from Postman, this could not get any response. But when I enter from a browser the service seems to be working, I have the service running in a local server, with a self signed SSL certificate.

When I perform a test form Hubspot susbcription edit panel, this shows a check icon.

This error started after migrating to https, in http worked fine.


#5

Hi, @yohanromeroc.

Thank you for that information. Could you clarify the following for me?

  1. I see that account 521251 is associated with app 27910, but it's unlike any developer account I have seen. Can you share a link to where you took that screenshot — where you can edit the app's settings and create webhook subscriptions?
  2. Did you test in Postman with the same webhook URL and payload shown in that screenshot? I don't know why you wouldn't get some response, so I'd like to test myself.

#7

Hi again, @yohanromeroc.

  1. I was able to get to your app by manually entering the URL path (since you're using an older account with developer tools, they do not appear in the navigation). No need to send me a link.
  2. Are you getting the following response from Postman?

First, can you confirm that you have SSL certificate verification turned off in the Postman settings, per this screencast?

I'll continue to try and dig in further.


#8

Hi Isaac,

Yes, I´m getting this reponse from Postman.
I´ve turned off the SSL certificate verification.


#9

Thanks for verifying that, @yohanromeroc.

I suspect the self-signed SSL certificate may be causing issues. Would you mind trying to use a Let's Encrypt cert?

In the past, I know other users have had success with these certificates.


#10

Hi,
I am getting the same error and we are using lets encrypt SSL.

Now how to debug this issue?


#12

Hi, @webacers.

Apologies for the delayed response. I left on vacation on 10 January and have just returned.

I see that you opened support ticket #2214238 with my colleague Janice and that you resolved the unknown error on your own by "changing the SSL."

Could you describe what you mean by this? Did you use another self-signed certificate, or an authority other than Let's Encrypt? I'd love to know in case other users experience this issue in the future!

Thanks in advance for your feedback.