Webhooks created in app settings not firing


#1

I've oauth'ed my app with a live account (set to private app because only we will be using it)
All seems to be connecting with the access token as I'm retrieving data if calling the API directly.

However, I've set up a webhook subscription to fire when the legal basis is updated within the app settings area (not via the API), and it's not firing.
I've checked that the endpoint is correct and working with the 'test' button - and received the output from console logging within my app to confirm this.

(edit)
So that it's clear, I have gone into the live account that we have with hubspot (with which my app is linked) with plenty of data to see whether any of the hooks fire when performing their associated actions, but they still aren't firing.

(edit 2)
I've checked this over several times, and can't work it out. Can I get some response from support please?!


#3

@mattca,

I appreciate your patience. We strive to respond to topics within two working days.

To troubleshoot effectively, I'll need a bit more information. Please share:

  1. Your production Hub ID.
  2. A link to the Webhook subscriptions tab of your app.

I tested my own subscription to the hs_legal_basis property on https://webhook.site and it worked perfectly:

If you run the same test, do you also successfully receive a payload?


#4

Hi Isaac,

Production hub id: 4063351

https://app.hubspot.com/developer/5064591/application/182880/webhooks

I've done the test too - at least with the button and it worked - and then, after having set it, Iogged into the production site and changed the legal basis on a customer's record, but the hook didn't fire.

I actually had 3 hooks set up at one point; 1 for the legal basis, 1 for when an email is opened and another for something else which I forget. None of them fired, as was evident from my lack of output in the console - i'm using heroku for app hosting - which I was watching, and the number of events listed against them in app settings said 0.


#5

(update)
It seems that the hs_legal_basis triggered when importing contacts.
However, I have a selection of other triggers in there and they don't seem to be firing.

I assume that I'm understanding these triggers correctly, but you don't seem to have some clear documentation written as to what each of these standard triggers (which can be enabled through the app settings) actually do.


#6

(update)
As I've had no luck getting the webhooks to work that are available through the app settings, I thought I would try first to see whether they are returned when using the API.

I get the following error:

{ StatusCodeError: 403 - {"status":"error","message":"This hapikey (omitted) does not have proper permissions! (requires all of [developers-access])


#7

Hi @mattca,

I don't see any subscription to hs_legal_basis here. Would you set up another one so I can run a few tests?

Which endpoint did you use to receive that last error? The developers-access scope generally references the fact that you need to use your developer API key rather than your production API key.


#8

TO ALL WHO MIGHT HAVE COME HERE WITH SIMILAR PROBLEMS:

Some simple things that aren't properly explained:

  • When creating webhooks, it's important to use your developer hapikey, not the one associated with the account that installs/integrates your app
  • If you have no luck setting a webhook, use something like Postman to post your raw JSON data to the webhook endpoint with your dev hapikey and userId
  • Dont use Oauth to create a webhook
  • After having set up your webhook (particularly, I found, when creating through the dev account) give it time to start working

Some thing that I've noted along the way:

  • It would make more sense to me if the webhooks were per integration instance, rather than all together in the dev account (maybe this I'm only seeing a particular view because I've selected private on my app)
  • Some of the webhooks simply do not fire, and this may be due to my account / settings, or simply that I was selecting the wrong one for my purpose
  • With regards to the above, it would be helpful to have a simple explanation next to the standard hooks when creating them through the dev account.