What does this error mean? bad gateway error


#1

I received error from hubspot API gateway but i don’t quite understand what’s happening. Do I need to do anything at my side?

api.hubapi.com | 502: Bad gateway body{margin:0;padding:0}
<div id="cf-error-details" class="cf-error-details-wrapper">
    <div class="cf-wrapper cf-error-overview">
        <h1>
          <span class="cf-error-type" data-translate="error">Error</span>
          <span class="cf-error-code">502</span>
        </h1>
        <h2 class="cf-subheadline" data-translate="error_desc">Bad gateway</h2>
    </div><!-- /.error-overview -->

    <div class="cf-section cf-highlight cf-status-display">
        <div class="cf-wrapper">
            <div class="cf-columns cols-3">
You

Browser

Working
Ashburn

Cloudflare

Working
api.hubapi.com

Host

Error
            </div>
        </div>
    </div><!-- /.status-display -->

    <div class="cf-section cf-wrapper">
        <div class="cf-columns two">
            <div class="cf-column">
                <h2 data-translate="what_happened">What happened?</h2>
                <p>The web server reported a bad gateway error.</p>
            </div>

            <div class="cf-column">
                <h2 data-translate="what_can_i_do">What can I do?</h2>
                <p data-translate="try_again_in_a_few">Please try again in a few minutes.</p>
            </div>
        </div>
    </div><!-- /.section -->

    <div class="cf-error-footer cf-wrapper">

Cloudflare Ray ID: xxxx Your IP: Performance & security by Cloudflare

</div><!-- /#cf-error-details -->

#2

Hi @richard,

502 errors are often returned by our load balancer if there is sustained traffic to a particular service for a particular portal. If you hold off on requests for a short while (~1-2 seconds) you should see these errors go away.


#3

Hi Derek,

I’m not clear what’s the sustained traffic we sent. I checked the API Call logging and analyzed API calls we sent at that time, it’s very few but we get this error.

This error happens several times this week and interrupted our workflow from time to time, so I want to understand more and see what’s the action we can take… But now I don’t have much idea…

For example, we got one such error today 7:29 am PST but we only have 3 requests at that moment (5 minutes window). Could you help take a look?


#4

Hi @richard,

Sorry for the confusion here. What I said before is true, but in this scenario it appears the 502s might be related to a different issue. We’re still working to identify what’s going on, so I’ll update this thread with more info when I have it.


#5

We are having the same problem here in the UK. We’ve been syncing with hubspot over the api for many months, but from the 4th January we’re getting random drop outs of service accompanied by 502s. We’re definitely not hitting the rate limiter as we’re rate limited at our end according to your policy to prevent that from happening.

This is an serious issue for our business and it is totally affecting normal service!

Please let us know what you are doing to resolve it.

Thanks,
Joe


#6

Hi all,

We pushed out a fix for this today; this should be resolved going forward. If you continue to consistently see these errors, feel free to bump this post / create a new one.